Back to overview
Degraded

Remote unable to process outbound email due to outage at provider (Mailgun)

May 27 at 01:52pm UTC
Affected services
Platform

Resolved
May 27 at 06:32pm UTC

Email delivery service is back to normal.

Updated
May 27 at 03:21pm UTC

We are again experiencing email delivery issues due to an outage of our email delivery provider, Mailgun. For the latest updates, please visit https://status.mailgun.com/

Updated
May 27 at 02:20pm UTC

Email delivery service is back to normal.

Created
May 27 at 01:52pm UTC

The Remote Platform uses Mailgun as its email deliverability service. Mailgun is currently experiencing a Major Outage and Remote is unable to process outbound e-mail as a consequence. Please follow https://status.mailgun.com/ for more updates.