Back to overview
Downtime

Platform downtime

Dec 19 at 12:18pm UTC
Affected services
Platform

Resolved
Dec 19 at 01:00pm UTC

We have fixed the situation and all services performing as expected. We appreciate your understanding.

Created
Dec 19 at 12:18pm UTC

employ.remote.com is down.

We apologize for the ongoing platform issues. Our team is actively working on resolving them. Expect intermittent service interruptions and slower response times. We appreciate your patience and will provide updates as we work towards a solution.

Thank you for your understanding.