Back to overview
Degraded

Performance degradation affecting our platform

May 5, 2026 at 9:00am UTC
Affected services
Platform
API

Resolved
May 5, 2026 at 12:00pm UTC

Platform performance: resolved. The immediate impact has been mitigated and performance has returned to normal. If you continue to experience any issues, please reach out to us.

Updated
May 5, 2026 at 10:04am UTC

The platform is currently recovering from the performance degradation incident. Our team is actively monitoring and controlling the situation. Some slowness may still be experienced while recovery completes.We'll share another update once the platform is fully restored. Thank you for your patience.

Created
May 5, 2026 at 9:00am UTC

We’re investigating a performance degradation affecting Remote's platform globally. Users may experience slow or unreliable behavior across core workflows. Mitigation work is in progress, we will keep this page updated with developments.